Back to overview
Downtime
whole server down
Sep 10, 2025 at 4:19am UTC
Affected services
proxs.us
Resolved
Sep 10, 2025 at 9:28pm UTC
Was fixed around 6AM
Affected services
Created
Sep 10, 2025 at 4:19am UTC
the bloody drive corrupted. i hope to have this patched, cloned, and fixed by morning!
Affected services